Question

I cannot use EndNote after upgrading my Mac OS to Catalina. What should I do?

Answer

There is a compatibility issue between the macOS 10.15 Catalina and EndNote for mac version X9.2 or before.  Please download and install the version X9.3.1 from our webpage to solve the compatibility issue.

 

You may refer to Install EndNote Desktop for the installation steps. 

 

For more details, please refer to our online guide for EndNote.


EndNote Tab